TAS7x00 Series Terahertz Spectroscopy & Imaging System
System Software
Operation Manual
(Quantitative Analysis Option)

MANUAL NUMBER 8702789-03

Applicable System
TAS7500
Legal Notices

All rights reserved. All text and figures included in this publication are the exclusive property of Advantest Corporation. Reproduction of this publication in any manner without the written permission of Advantest Corporation is prohibited. Information in this document is subject to change without notice.

Trademarks and Registered Trademarks

• ADVANTEST is a trademark of Advantest Corporation.

• All other marks referenced herein are trademarks or registered trademarks of their respective owners.

• The Unscrambler® X and OLU PX are trademarks of CAMO Software, Inc.
## Revision History

<table>
<thead>
<tr>
<th>Rev.</th>
<th>Date</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>Apr 16/12</td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>Nov 5/12</td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>Mar 31/14</td>
<td></td>
</tr>
</tbody>
</table>
# Table of Contents

**Preface** ............................................................................................................. Preface-1

Purpose of This Manual ................................................................................ Preface-1
Related Manuals ............................................................................................. Preface-1

1. **Overview** ................................................................................................ 1-1

2. **The Unscrambler® X** ...................................................................... 2-1

3. **Installation and Uninstall** ........................................................... 3-1
   3. 1 Installation ............................................................................................. 3-1
   3. 2 Uninstall .............................................................................................. 3-2

4. **License Management** ..................................................................... 4-1
   4. 1 Registering Licenses ............................................................................ 4-1
   4. 2 Deleting Licenses .................................................................................. 4-3

5. **Operating Procedures** .................................................................... 5-1
   5. 1 Saving Spectrum Files ......................................................................... 5-1
   5. 2 Creating Quantification Model Files .................................................. 5-4
   5. 3 Performing Quantification ................................................................. 5-10

6. **Menu Details** ................................................................................... 6-1
   6. 1 Graph Window of Analyze Window .................................................. 6-1
   6. 2 Save data table Dialog Box ................................................................. 6-3
   6. 3 Quantification Dialog Box ................................................................. 6-4
   6. 4 Properties Dialog Box ........................................................................... 6-6
7. Glossary .................................................................................................................. 7-1
  7. 1 Spectrum File .................................................................................................. 7-1
  7. 2 Quantification Model File ............................................................................. 7-2

List of Figures .......................................................................................................... F-1
Preface

Purpose of This Manual

This manual describes how to install the quantitative analysis option used with the System Software, how to register the license, and how to operate the quantitative analysis option, as well as its functions.

Related Manuals

TAS7500 Series Terahertz Spectroscopy & Imaging System Instruction Manual

This manual describes the procedures required to perform measurement and analysis operations including handling notes for safe use, after the system is installed.

TAS7x00 Series Terahertz Spectroscopy & Imaging System System Software Operation Manual

This manual describes how to operate the system software for spectroscopic measurements/analyses and imaging measurements/analyses using the TAS7x00 Series Terahertz Spectroscopy & Imaging System.
1. **Overview**

The quantitative analysis option creates a quantification model from multiple spectra and provides a function that estimates the quantity of a component from the spectra measured by using the model.
2. The Unscrambler® X

The Unscrambler® X is a multivariate analysis tool of CAMO Software, Inc.

The Unscrambler® X is required in order to execute quantitative analyses using this option.

The Unscrambler® X is used to create a quantification model file.

➤ For more information on quantification model files, refer to 7.2 "Quantification Model File" on page 7-2.

Users of this option need to have knowledge of spectrum multivariate analysis and The Unscrambler® X.

The operating procedures for The Unscrambler® X described in this manual are the minimum procedures for creating a quantification model file that can be used for this option.

➤ For more information, refer to the manuals for The Unscrambler® X.

The version of quantification model files supported by this option is 10.1 and 10.2.

The operating procedures for The Unscrambler® X described in this manual are based on version 10.1. Note that the procedures may be different if a different version is used.
3. **Installation and Uninstall**

This chapter describes how to install and uninstall the quantitative analysis option.

3. 1 **Installation**

The procedure for installing the quantitative analysis option is as follows:

1) Put the quantitative analysis option installation CD in the disk tray.

2) Use Explorer to display the folders on the CD-ROM.

3) Right click InstallTAS7x00Quantification.bat and click **[Run as administrator (A) ...]**.

4) The User Account Control dialog box opens. Click the **[OK]** button to start installation.
   - **Quantification execution library (OLUPX)**
     The quantification execution library is installed. Various dialog boxes appear sequentially. Press the **[Next >]** button in each dialog box with the default settings to proceed with the installation. Press the **[Finish]** button to complete the installation.
     During installation, the operator is asked to enter the Activation Key on the Personal Information input screen. Enter the Activation Key sent by Advantest on this screen.

5) When **[Press any key to continue...]** is displayed on the command prompt screen, press the **[Enter]** key to exit.

The installation of the quantitative analysis option is now complete.

After installation, register the license to enable its functions.

⇒ For more information on how to register the license, refer to 4. 1 "Registering Licenses" on page 4-1.
3. 2 Uninstall

The procedure for uninstalling the quantitative analysis option is as follows:

1) Select [Start] → [All Programs] → [TAS7x00] → [Uninstall TAS7x00 Quantification]
   and click it with the right mouse button, and then click [Run as administrator (A) ...].

2) The User Account Control dialog box opens. Click the [OK] button to start uninstall.

3) This will uninstall the quantification execution library (OLUPX). Click the [OK] button to start
   uninstall. Press the [OK] button to complete the uninstall.

4) When [Press any key to continue...] is displayed on the command prompt screen, press the
   [Enter] key to exit.

The uninstall of the quantitative analysis option is now complete.

After uninstall, be sure to delete the license.

⇒ For more information on how to delete the license, refer to 4. 2 "Deleting Licenses" on
  page 4-3.
4. **License Management**

This chapter describes the license management of the functions for this option. By registering the license, the functions for this option become enabled.

This option can be registered on one computer per license.

To register a license, a password sheet is required.

Password sheets include online and offline versions.

Each product number is as follows:

- Online version: PYSI75-02M
- Offline version: PYSA75-02M

The following descriptions use the online version as an example.

4. 1 Registering Licenses

The procedure for registering a license is as follows:

1) Prepare the password sheet sent by Advantest.

2) Select [Start] → [All Programs] → [Accessories] → [Command Prompt] and click it with the right mouse button, and then click [Run as administrator (A) ...].

3) The User Account Control dialog box opens. Click the [OK] button.

4) To register a license, enter the command using the line that begins with "CpuFixed 000 ..." (shown in Figure 4-1) as an argument.

The following shows an example execution:
4–2
4. License Management

Figure 4-2    Example Execution of License Registration

C:\>%PLMS_ROOT%\bin\License_Add  CpuFixed 000 AA9DCC963F0B685A9FDF710091C164E9A0 00000edcba98 PYSI75-02M 2017/03/22 1 00000edcba98 License Added
C:\>
4. 2 Deleting Licenses

The procedure for deleting a license is as follows:

1) Prepare the password sheet used in 4. 1 "Registering Licenses" on page 4-1.

2) Select [Start] → [All Programs] → [Accessories] → [Command Prompt] and click it with the right mouse button, and then click [Run as administrator (A) ...].

3) The User Account Control dialog box opens. Click the [OK] button.

4) Entering the license deletion command displays a list of registered licenses. Enter the label number that includes a line beginning with "CpuFixed 000 ..." in the password sheet and enter [y] to delete the license.

The following shows an example execution.

**Figure 4-3 Example Execution of License Deletion**

```plaintext
C:\>%PLMS_ROOT%\bin\License_Rem\ (1):CpuFixed 000 AA9DCC963F0B685A9FDF710091C164E9A00000edcba98 PYSI75-02M 2017/03/22 1 00000edcba98
Input the label Number for the product that you want to delete. [1] or Quit[Q]:1
(1):CpuFixed 000 AA9DCC963F0B685A9FDF710091C164E9A00000edcba98 PYSI75-02M 2017/03/22 1 00000edcba98
Will be Deleted. [Y/N]:y
License Removed

C:\>
```

2/25/14
5. Operating Procedures

This chapter describes the operating procedures for quantitative analysis. The procedures are as follows:

1) Display multiple spectra, which are sources for creating quantification models, in the Analyze window
   Either execute a measurement to transfer the spectra to the Analyze window or load the spectrum measurement data file.
2) Overlay the displayed spectra in a graph window
   To copy the waveform to another graph window, select the spectra to copy and press [Ctrl+C], and then select a graph window on which the copied waveform is to be overlaid and press [Ctrl+V].

If the quantification model file already exists, the procedures described in 5.1 "Saving Spectrum Files" on page 5-1 and 5.2 "Creating Quantification Model Files" on page 5-4 are not needed.

The following subsections describe the details of the preceding steps.

5.1 Saving Spectrum Files

- Save multiple spectra that were measured with the System Software to a file. This file is called a spectrum file.
  - For more information on spectrum files, refer to 7.1 "Spectrum File" on page 7-1.

5.2 Creating Quantification Model Files

- Use The Unscrambler® X to load the spectrum file, create a quantification model, and save it to a file. This file is called a quantification model file.
  - For more information on quantification model files, refer to 7.2 "Quantification Model File" on page 7-2.

5.3 Performing Quantification

- Use the System Software to load the quantification model file, apply the model to the measured spectra, and quantify the desired component.
Figure 5-1   Graph Window Displaying Multiple Spectra

Important

Unless the following conditions agree, the waveform cannot be overlaid.

- Type of vertical axis
- Type of horizontal axis
- Number of data items to display

Tip

When loading a spectrum measurement data file from [File] → [Load PointData...] in the Analyze window, by selecting more than one file and loading them together, all of the spectra are overlaid and displayed in one graph window, saving you the trouble of having to overlay them later.
3) Click [File] → [Save data table...] in the graph window. The Save data table dialog box opens.

**Figure 5-2  Save data table Dialog Box**

![Save data table dialog box](image)

The names and information of all the spectra in the graph window are displayed in the dialog box.
Select the names of the spectra to save. To select a name, check the checkboxes under Name. Click the [Save...] button and enter a file name to save the file.
Here, the file is saved with the name "SpectraTable.csv" as an example.

---

**Important**

If any of the following conditions does not agree, multiple spectra cannot be selected.

- Type of vertical axis
- Type of horizontal axis
- Number of data items to display
- Data interval
- Data range
5.2 Creating Quantification Model Files

1) Start The Unscrambler® X
   Execute [Start] → [All Programs] → [The Unscrambler® X 10.1 (64-bit)] → [The
   Unscrambler® X 10.1 (64-bit)].

2) Load the spectrum file
   Click [File] → [Import Data] → [ASCII...]. In the file load dialog box, specify the spectrum
   file (SpectraTable.csv) that was created in the previous section. The ASCII Import dialog box
   opens. Click the [OK] button.

Figure 5-3 ASCII Import Dialog Box

3) The table of spectra that have been loaded in the main window is displayed.
4) Use the mouse to select the column of number 1, and then right click the mouse on the column and execute [Insert] → [Row(s)/Column(s)...].
In the Insert Columns dialog box, enter 1 in Number of new columns and click the [OK] button.
Enter the component name in the column title and component values in the columns corresponding to each spectrum.
Here, Thickness is entered as the component name as an example.

* To perform a quantitative analysis on more than one component, add as many columns as the number of components to be added.

5) Create an input variable table (X)
Select all columns other than Thickness, and then right click the mouse and execute [Create Column Range]. Columnset is added to the tree. Select Columnset, and then right click the mouse and select [Rename] to change the name to X.

**Figure 5-6 Input Variable Table**

6) Create an output variable table (Y)
Select the Thickness column, and then right click the mouse and execute [Create Column Range]. Columnset is added to the tree. Select Columnset, and then right click the mouse and select [Rename] to change the name to Y.

**Figure 5-7 Output Variable Table**
7) Execute partial least squares regression (PLSR)
   Execute [Tasks] → [Analyze] → [Partial Least Squares Regression ...]. The Partial Least Squares dialog box opens.

**Figure 5-8 Partial Least Squares Dialog Box**

Click the [OK] button. The View Plots dialog box opens. Click the [OK] button to display the PLSR results.
8) Save the model to a file

Select PLS on the tree, and then right click the mouse and execute [Save Model]. The Save Model dialog box opens.
Figure 5-10  Save Model Dialog Box

Leave the Entire model radio button on and click the [OK] button. Enter a file name and save the file. Here, PLS.unsb is used as the file name. The unsb file which was saved here is the quantification model file.

This completes the description of the operations of The Unscrambler® X.
5. 3 Performing Quantification

1) Display spectra for which to perform quantification in the Analyze window
   Either execute a measurement to transfer the spectra to the Analyze window or load the spectrum
   measurement data file.

2) Click [Analysis] → [Quantification] in the graph window. The Quantification dialog box
   opens.

![Quantification Tab in Quantification Dialog Box](image)

3) Select the Quantification tab.

4) Now load a quantification model file. Click the [Browse...] button and select PLS.unsb which
   was created in the previous section.

5) A list of spectrum names is displayed in Quantification data. Check the Name checkboxes of the
   spectra to be quantified and click the [Quantify] button.

--- Important ---

Selected spectra must have the same vertical axis as those that were used to create the
quantification model. Note that correct quantititative values may not be obtained if their vertical
axes are different.
6) The Result tab is displayed if quantification has been successfully completed. The quantification results are displayed in Quantification result. The results of all the spectra that were selected in Quantification data are displayed. The quantitative values for each component shown in Component are displayed in the Y-Predicted columns. Quantification results can be saved to a text file by pressing the [Save...] button.

**Figure 5-12 Result Tab of Quantification Dialog Box**
6. **Menu Details**

This chapter describes the menus used to execute a quantitative analysis.

6. 1 **Graph Window of Analyze Window**

Quantitative analyses are executed by using menus in the graph window of the Analyze window.

**Figure 6-1  Graph Window of Analyze Window**

- **[File] → [Save data table...]**

  This command saves multiple spectra used to create a quantification model to a file.

  Clicking this command opens the Save data table dialog box.

  ➔ For more information on the dialog box, refer to 6. 2 "Save data table Dialog Box" on page 6-3.
◆ [Analysis] → [Quantification]

This command executes quantification. Clicking this command opens the Quantification dialog box.

⇒ For more information on this dialog box, refer to 6.3 "Quantification Dialog Box" on page 6-4.

◆ Right click the mouse → [Properties...]

This command allows users to reference quantification results of the selected spectra. Clicking this command opens the Properties dialog box.

⇒ For more information on the dialog box, refer to 6.4 "Properties Dialog Box" on page 6-6.
6. 2 Save data table Dialog Box

This dialog box is used to create a spectrum file.

For more information on spectrum files, refer to 7. 1 "Spectrum File" on page 7-1.

This dialog box is opened from [File] → [Save data table...] in 6. 1 "Graph Window of Analyze Window" on page 6-1.

Figure 6-2 Save data table Dialog Box

![Save data table Dialog Box]

- **Name**: Spectrum name
- **Vertical axis**: Vertical axis for the spectrum
- **Horizontal axis**: Horizontal axis for the spectrum
- **Number of points**: Number of data items to display for the spectrum
- **Interval**: Data interval for the spectrum
- **Range**: Data range for the spectrum

- **[Select All] button**: Selects all spectra.
- **[Save...] button**: Saves spectra to a file. Clicking this button opens the File Save dialog box.
- **[Close] button**: Closes the dialog box.
6. 3 Quantification Dialog Box

This dialog box performs quantification using a quantification model file. Quantification results can be saved to a text file.

➔ For more information on quantification model files, refer to 7. 2 "Quantification Model File" on page 7-2.

This dialog box is opened from [Analysis] → [Quantification] in 6. 1 "Graph Window of Analyze Window" on page 6-1.

Figure 6-3 Quantification Dialog Box
6. 3 Quantification Dialog Box

◆ Quantification tab

[Browse...] button Loads a quantification model file.

Quantification model Displays quantification model information.
  Model path Name of the path of the loaded quantification model file
  Model name Model name selected in the quantification model file
  Components Names of components that were specified when the model was created
  Components used Number of components that were specified when the model was created
  Number of points Number of data items to display for the spectrum that were used when the model was created

Quantification data Displays spectra information. Spectra to be quantified are selected by checking the checkboxes.
  Name Spectrum name
  Vertical axis Vertical axis for the spectrum
  Horizontal axis Horizontal axis for the spectrum
  Number of points Number of data items to display for the spectrum
  Interval Data interval for the spectrum
  Range Data range for the spectrum

[Select All] button Checks the checkboxes of the spectra that have already been selected. If not any spectra has been selected, spectra which satisfy the same conditions of the first spectrum are searched for from the remaining spectra, and their checkboxes are checked.

[Quantify] button Quantifies the selected spectra and displays the results in Quantification result of the Result tab.

◆ Result tab

Quantification result Displays quantification results.
  Name Name of the quantified spectrum
  Component Name of the quantified component
  Y-Predicted Quantitative value
  Y-Deviation Deviation
  Hotelling’s T2 T2 statistic (an index that indicates the validity of a quantification model)
  X Sample Q-Residuals Residual (an index that indicates the validity of a quantification model)

[Save] button Saves the quantification results shown in Quantification result to a text file.

[Close] button Closes the dialog box.
6. 4 Properties Dialog Box

Quantification results of spectra can be referenced by using the Quantification tab in this dialog box.

This dialog box is opened from right click → [Properties...] in 6.1 "Graph Window of Analyze Window" on page 6-1.

**Figure 6-4  Quantification Tab in Properties Dialog Box**

![Properties Dialog Box]

- **Model path**
  - Name of the path of the quantification model file used for quantification

- **Hotelling’s T2**
  - T2 statistic (an index that indicates the validity of a quantification model)

- **X Sample Q-Residuals**
  - Residual (an index that indicates the validity of a quantification model)

- **Component**
  - Name of the quantified component

- **Y-Predicted**
  - Quantitative value

- **Y-Deviation**
  - Deviation
7. **Glossary**

This chapter describes the terms used in this manual.

7. 1 **Spectrum File**

This is a file which stores multiple spectra.

The file format is CSV (comma separated value).

This file is used to create a quantification model using The Unscrambler® X.

This file is created from the [File] → [Save data table...] menu in a graph window in the Analyze window.
7. 2 Quantification Model File

This is a file which stores models used for executing quantification.

The file format is the standard file format of The Unscrambler® X (the extension is .unsb).

This file is loaded by using the System Software and is used to execute quantification.
List of Figures

Figure 4-1 Sample Password Sheet (CpuFixed) ............................................. 4-1
Figure 4-2 Example Execution of License Registration ................................. 4-2
Figure 4-3 Example Execution of License Deletion ....................................... 4-3
Figure 5-1 Graph Window Displaying Multiple Spectra ............................... 5-2
Figure 5-2 Save data table Dialog Box ......................................................... 5-3
Figure 5-3 ASCII Import Dialog Box ............................................................. 5-4
Figure 5-4 Main Window in which Spectrum File Has Been Loaded .............. 5-5
Figure 5-5 Main Window in which Thickness Has Been Added .................... 5-5
Figure 5-6 Input Variable Table ................................................................. 5-6
Figure 5-7 Output Variable Table ............................................................... 5-6
Figure 5-8 Partial Least Squares Dialog Box ............................................... 5-7
Figure 5-9 PLSR Results ............................................................................ 5-8
Figure 5-10 Save Model Dialog Box ......................................................... 5-9
Figure 5-11 Quantification Tab in Quantification Dialog Box ....................... 5-10
Figure 5-12 Result Tab of Quantification Dialog Box .................................. 5-11
Figure 6-1 Graph Window of Analyze Window .......................................... 6-1
Figure 6-2 Save data table Dialog Box ......................................................... 6-3
Figure 6-3 Quantification Dialog Box ............................................................ 6-4
Figure 6-4 Quantification Tab in Properties Dialog Box .............................. 6-6